Benutzer-Werkzeuge

Webseiten-Werkzeuge


vdr:vdpau_failed

Dies ist eine alte Version des Dokuments!


A PCRE internal error occured. This might be caused by a faulty plugin

====== VDPAU läuft nicht (Failed to load...) ====== Auch wenn es bei mir nicht beim Betrieb vom VDR aufgefallen ist (bei mir war es crashender Firefox), so passt das Thema doch am ehesten hier rein. Falls ihr einen Fehler "Failed to open VDPAU backend libvdpau_nvidia.so” bekommt oder im Log findet, so ist ein fehlender symbolischer Link die Ursache. Im Netz findet man häufiger die Lösung, ein Link /usr/lib/libvdpau_nvidia.so zu setzen, der aber nicht wirklich hilft. Tatsächlich fehlt (zusätzlich) ein zweiter Link /usr/lib64/libvdpau_va_gl.so! Die Lösung sieht dann so aus: 64-Bit <code> rm -f /usr/lib64/libvdpau_nvidia.so rm -f /usr/lib64/libvdpau_va_gl.so ln -s /usr/lib64/vdpau/libvdpau_nvidia.so.1 /usr/lib64/libvdpau_nvidia.so ln -s /usr/lib64/vdpau/libvdpau_va_gl.so /usr/lib64/libvdpau_va_gl.so </code> 32-Bit <code> rm -f /usr/lib/libvdpau_nvidia.so rm -f /usr/lib/libvdpau_va_gl.so ln -s /usr/lib/vdpau/libvdpau_nvidia.so.1 /usr/lib/libvdpau_nvidia.so ln -s /usr/lib/vdpau/libvdpau_va_gl.so /usr/lib/libvdpau_va_gl.so </code> vdpauinfo sollte dann etwas ausspucken: <code> display: :0 screen: 0 [VS] Software VDPAU backend library initialized libva info: VA-API version 0.34.0 libva info: va_getDriverName() returns 0 libva info: Trying to open /usr/lib64/dri/nvidia_drv_video.so libva info: Found init function __vaDriverInit_0_34 [...] </code> Wenn alles passt, sollten auch die Codecs aufgelistet werden.

vdr/vdpau_failed.1429602785.txt.gz · Zuletzt geändert: 21.04.2015 07:53 (Externe Bearbeitung)